High Load / Slow Performance
Incident Report for PeopleSafe Limited
Resolved
We are pleased to say that our increased capacity and performance mitigations are working well. We are continuing to see a massive amount of system load, particularly with Online Learning, but PeopleSafe is operating as expected.
We will continue to closely monitor this and make further refinements. Thanks to everyone for their patience while we've managed this.
Posted Aug 31, 2021 - 12:50 NZST
Update
With very high load continuing throughout the evening, PeopleSafe application performance has improved as we've brought on more capacity, We'll continue to monitor this and update further on Tuesday morning as we expect this spike in usage to continue ahead of the change to Covid-19 Alert Level 3.
Thank you to everyone for their patience while we work through this short period.
Posted Aug 31, 2021 - 01:16 NZST
Monitoring
We are currently experiencing extremely high load on PeopleSafe while many essential businesses keep their staff safe under Covid-19 Level 4, and many businesses prepare for work under Level 3. The extremely high use of Online Learning in particular is currently impacting performance with PeopleSafe slower than ideal.

Our data center partner and development team are currently working on this. We apologise for the inconvenience and thank you for your patience in the meantime.
Posted Aug 30, 2021 - 15:35 NZST
This incident affected: PeopleSafe Application.